爬牛论坛

 找回密码
 立即注册
搜索
查看: 1317|回复: 73

[其他教程] 批量检测手机号是否开通微博+详细教程+源码+成品

  [复制链接]

27

主题

36

帖子

238

积分
UID 9991
牛币:
192 个

贡献:
10 个

威望:
0 点

我的勋章

最佳新人

会飞的鱼作者认证 发表于 2019-4-8 12:34:57
最近公司做营销,需要手机号是否注册哪些网站。然后这个艰巨的任务交给了我。 批量检测手机号是否开通微博+详细教程+源码+成品-1.gif
在网上找教程找成品,都没有!当时还以为挺难的,就自己琢磨了几个小时,成功写出。(第一次用易语言写POST,GET有不足的地方,望指导。)

顺手出个教程!一起研究。

1.项目分析,检测手机号是否注册微博。(想到的是注册时候输入手机号,通过ajax校验手机号是否注册)
批量检测手机号是否开通微博+详细教程+源码+成品-2.png 批量检测手机号是否开通微博+详细教程+源码+成品-3.png

(通过图片对比,当手机号注册过时候提示:手机号以注册,当手机号没有注册时候,后面是一个图片。抓包看是GET还是POST请求。如果是GET就好办了)

2.抓包准备:火狐浏览器

这里我使用的是火狐自带抓包工具,按F12开启调试模式,选择网络。开始干干干


(是GET请求,如果是GET请求就好办了。GET请求参数是可以看到的,方便自己传参使用。如果是POST我就凉凉了,不会搞POST的,昨晚发帖求助大婶,没人理我。POST的牵扯到加密解密问题)
把控制台抓包的数据复制出来,简单分析一下。
批量检测手机号是否开通微博+详细教程+源码+成品-4.png
https://weibo.com/signup/v5/formcheck?type=mobilesea&zone=0086&value=XXXXX&from=&__rnd=1554652400081
这是抓包的数据。value后面跟的XXXXX是你们输入的手机号。现在知道value的作用,还有一个rnd的值需要注意。当时我把rnd删除掉,结果没有返回数据,就觉得事情不是那么简单。
最后每次抓包发现rnd的值都在变化,但是都是155239前部分没有变化,变化的是时候的数字,每次都增加很多,然后就大胆猜测了一下,这个数字应该是获取的时间戳(自1970-1-1 00:00:00 - 到现在的毫米值,经判断发现是正确的。)

GET请求分析好了,参数也明白了。就用易语言编写个简单的代码,测试两拨数据(一个注册过帐号,一个没有注册过帐号,经过比对,返回的数据如下)
批量检测手机号是否开通微博+详细教程+源码+成品-5.png 批量检测手机号是否开通微博+详细教程+源码+成品-6.png



-----------------------------------------------------下面是代码-------------------------------------


批量检测手机号是否开通微博+详细教程+源码+成品-7.png

[Erlang] [color=rgb(51, 102, 153) !important]纯文本查看 [color=rgb(51, 102, 153) !important]复制代码
[backcolor=rgb(27, 36, 38) !important][color=white !important]
[color=white !important]?

01

02

03

04

05

06

07

08

09

10

11

12

13

14

15

16

17

18

19

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 url, 文本型

.子程序 _按钮1_被单击

url = 到文本 (网页_访问_对象 (“https://weibo.com/signup/v5/formcheck?type=mobilesea&zone=0086&value=” + 编辑框1.内容 + “&from=&__rnd=” + 到文本 (时间_取现行时间戳 ()), 0, , “UOR=cuiqingcai.com,widget.weibo.com,cuiqingcai.com; SINAGLOBAL=4488993145257.228.1526896503332; SCF=AlC33K5qfoC7HrROfBB4mJtN4jIrVfmOXc5lAUlmorulSufEgLxzAoaGm9UpO3hHKasTrfkIe_0LeF5Zd8gRv7M.; SUHB=0nlfv7xtsoHJQt; YF-Ugrow-G0=ad83bc19c1269e709f753b172bddb094; SUB=_2AkMsSHHIf8NxqwJRmP4RzmvkaY9_yQ_EieKaFIATJRMxHRl-yT83qkYgtRB6B8hfJraHaIVDNybz4ulKcpL4rU8_KteM; SUBP=0033WrSXqPxfM72-Ws9jqgMF55529P9D9WFzw.rJdFEwdBoiQG9_E9Hi; login_sid_t=c8537f18996d44a673568d321f8c5072; cross_origin_proto=SSL; YF-V5-G0=16139189c1dbd74e7d073bc6ebfa4935; WBStorage=5548c0baa42e6f3d|undefined; _s_tentry=passport.weibo.com; wb_view_log=1366*7681; __lnkrntdmcvrd=-1; Apache=6358580283442.719.1528102658639; ULV=1528102658655:2:1:1:6358580283442.719.1528102658639:1526896504059; appkey=”, , “Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36”))



编辑框2.内容 = url

.子程序 _按钮2_被单击

url = 到文本 (网页_访问_对象 (“https://weibo.com/signup/v5/formcheck?type=mobilesea&zone=0086&value=” + 编辑框5.内容 + “&from=&__rnd=” + 到文本 (时间_取现行时间戳 ()), 0, , “UOR=cuiqingcai.com,widget.weibo.com,cuiqingcai.com; SINAGLOBAL=4488993145257.228.1526896503332; SCF=AlC33K5qfoC7HrROfBB4mJtN4jIrVfmOXc5lAUlmorulSufEgLxzAoaGm9UpO3hHKasTrfkIe_0LeF5Zd8gRv7M.; SUHB=0nlfv7xtsoHJQt; YF-Ugrow-G0=ad83bc19c1269e709f753b172bddb094; SUB=_2AkMsSHHIf8NxqwJRmP4RzmvkaY9_yQ_EieKaFIATJRMxHRl-yT83qkYgtRB6B8hfJraHaIVDNybz4ulKcpL4rU8_KteM; SUBP=0033WrSXqPxfM72-Ws9jqgMF55529P9D9WFzw.rJdFEwdBoiQG9_E9Hi; login_sid_t=c8537f18996d44a673568d321f8c5072; cross_origin_proto=SSL; YF-V5-G0=16139189c1dbd74e7d073bc6ebfa4935; WBStorage=5548c0baa42e6f3d|undefined; _s_tentry=passport.weibo.com; wb_view_log=1366*7681; __lnkrntdmcvrd=-1; Apache=6358580283442.719.1528102658639; ULV=1528102658655:2:1:1:6358580283442.719.1528102658639:1526896504059; appkey=”, , “Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36”))


编辑框4.内容 = url







‘未注册新浪微博的手机号返回数据:{"code":"100000","data":{"id":"","state":true,"type":"ok","code":"100000","action":"io","msg":"","iodata":""},"msg":""}
注册新浪微博的手机号返回数据:{"code":"600001","data":{"id":"","state":true,"type":"err","code":"600001","action":"io","msg":"u8be5u624bu673au53f7u5df2u6ce8u518cuff0cu53ef<a href="javascript:void(0)" action-type="btn_login">u76f4u63a5u767bu5f55</a>","iodata":""},"msg":""}

-----------------------------------------------------上面是代码-------------------------------------

使用多个手机号多次测试,未注册的手机号返回的数据:100000,注册过的手机号返回的数据:600001

返回数据也有了,只需要获取到100000和600001的数值就可以进行判断手机是否注册微博了。这里我使用的是代码是:

到数值 (取文本左边 (到文本 (文本区分_只取数字 (url)), 6))


先只获取返回参数里面的数字,然后在截取掉前6位,就获取到数值了,然后在进行判断即可。


3.最后使用批量验证(手机号如果多次检测会提示:注册频繁。但是返回的数据是注册过的数据,这一点不知道怎么改善,想的是,用易语言写个代{过}{滤}理,然后循环执行多少次之后就更换IP)
直接上代码了,代码加的有注释,这里我加上了线程(对易语言的线程使用还不是太了解,不使用线程的话程序直接卡死了。)

-----------------------------------------------------下面是代码-------------------------------------
[C] 纯文本查看 复制代码
.版本 2
.支持库 EThread
.支持库 eAPI
 
 
.程序集 窗口程序集_启动窗口
.程序集变量 Code, 文本型
.程序集变量 lineDate, 文本型, , "0"
 
 
.子程序 _按钮1_被单击
 
 
启动线程 (&子程序1, 100000000000, )
 
 
 
 
.子程序 _按钮2_被单击
 
 
启动线程 (&子程序2, 100000000000, )
 
 
.子程序 子程序2
 
 
 
 
通用对话框1.初始目录 = 取运行目录 ()
.判断开始 (通用对话框1.打开 ())
    _启动窗口.标题 = 通用对话框1.文件名
    编辑框1.内容 = 到文本 (读入文件 (通用对话框1.文件名))
.默认
 
 
.判断结束
 
 
 
 
.子程序 子程序1
.局部变量 i, 整数型
.局部变量 LineNumber, 文本型
 
 
.判断开始 (编辑框1.内容 = “”)
    信息框 (“请输入手机号或导入手机号”, 0, , )
    返回 ()
.默认
 
 
.判断结束
 
 
lineDate = 分割文本 (编辑框1.内容, #换行符, )
 
 
.计次循环首 (取数组成员数 (lineDate), i)
    url = 到文本 (网页_访问_对象 (“[url]https://weibo.com/signup/v5/formcheck?type=mobilesea&zone=0086&value=[/url]” + lineDate [i] + “&from=&__rnd=” + 到文本 (时间_取现行时间戳 ()), 0, , “UOR=cuiqingcai.com,widget.weibo.com,cuiqingcai.com; SINAGLOBAL=4488993145257.228.1526896503332; SCF=AlC33K5qfoC7HrROfBB4mJtN4jIrVfmOXc5lAUlmorulSufEgLxzAoaGm9UpO3hHKasTrfkIe_0LeF5Zd8gRv7M.; SUHB=0nlfv7xtsoHJQt; YF-Ugrow-G0=ad83bc19c1269e709f753b172bddb094; SUB=_2AkMsSHHIf8NxqwJRmP4RzmvkaY9_yQ_EieKaFIATJRMxHRl-yT83qkYgtRB6B8hfJraHaIVDNybz4ulKcpL4rU8_KteM; SUBP=0033WrSXqPxfM72-Ws9jqgMF55529P9D9WFzw.rJdFEwdBoiQG9_E9Hi; login_sid_t=c8537f18996d44a673568d321f8c5072; cross_origin_proto=SSL; YF-V5-G0=16139189c1dbd74e7d073bc6ebfa4935; WBStorage=5548c0baa42e6f3d|undefined; _s_tentry=passport.weibo.com; wb_view_log=1366*7681; __lnkrntdmcvrd=-1; Apache=6358580283442.719.1528102658639; ULV=1528102658655:2:1:1:6358580283442.719.1528102658639:1526896504059; appkey=”, , “Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36”))
 
 
    .判断开始 (到数值 (取文本左边 (到文本 (文本区分_只取数字 (url)), 6)) = 600001)
        编辑框2.加入文本 (lineDate [i] + #换行符)
    .默认
        编辑框3.加入文本 (lineDate [i] + #换行符)
    .判断结束
 
 
.计次循环尾 ()
写到文件 (取运行目录 () + “\注册过新浪手机号.txt”, 到字节集 (编辑框2.内容))
写到文件 (取运行目录 () + “\未注册过新浪手机号.txt”, 到字节集 (编辑框3.内容))
信息框 (“检测完毕!”, 0, , )
 
 
 
 
.子程序 _按钮3_被单击
 
 
编辑框1.内容 = “”
编辑框2.内容 = “”
编辑框3.内容 = “”
 
 
.子程序 _按钮4_被单击
 
 
打开指定网址 (“tencent://message/?uin=XXXX”)
 
 
 
 
.子程序 _编辑框1_获得焦点
 
 
编辑框1.内容 = “”
编辑框2.内容 = “”
编辑框3.内容 = “”

-----------------------------------------------------上面是代码-------------------------------------

注意!注意!注意!如果检测过多手机号,就会出现频繁默认都是未注册或已注册!

之前发过该帖子但是不小心留了联系方式被删帖,本次更新删除了所有的联系方式,打码手机号。
如果以上代码出现乱码问题,请直接下载源码,自己观摩。
如有需要添加功能的,请在下面留言。
本次更新:
1.增加功能:显示手机号注册和未注册信息
2.增加功能:导出未注册和注册手机号到本地
3.修复功能:导出本地出现一个手机号出现未注册和注册列表中

成品截图: 批量检测手机号是否开通微博+详细教程+源码+成品-8.png

成品下载地址: 链接: https://share.weiyun.com/5we5h2v (密码:BdGo)
源码下载地址:链接: https://share.weiyun.com/5Ac3gar (密码:7t15)


千万莫浪,由于IP限制,每次推荐不要导入太多的手机号,不然装逼不成就会成以下效果(作者作死,导入了2000个手机号)
如果出现了这种情况,不要紧张,不要害怕,不要怂。关掉网页,关掉工具,静静等待一分钟后可以继续干undefined(微博好强大,1分钟就能继续检测手机号了,好J8OK)
批量检测手机号是否开通微博+详细教程+源码+成品-9.png

回复

使用道具 举报

0

主题

2

帖子

16

积分
UID 7054
牛币:
14 个

贡献:
0 个

威望:
0 点

我的勋章
gpy7445xt0 发表于 2019-4-8 12:35:03
回的人少,我来小顶一下
回复

使用道具 举报

0

主题

2

帖子

15

积分
UID 1000
牛币:
13 个

贡献:
0 个

威望:
0 点

我的勋章

最佳新人

krxerxz0d0 发表于 2019-4-8 12:35:18
额,看不懂在说神马~@_@
回复

使用道具 举报

0

主题

1

帖子

13

积分
UID 8482
牛币:
12 个

贡献:
0 个

威望:
0 点

我的勋章
fwkekdhdvv 发表于 2019-4-8 12:36:43
我只是路过打酱油的
回复

使用道具 举报

0

主题

1

帖子

13

积分
UID 1442
牛币:
12 个

贡献:
0 个

威望:
0 点

我的勋章

最佳新人

06srjiv7af 发表于 2019-4-8 12:43:29
啥也不说了,感谢楼主分享哇!
回复

使用道具 举报

0

主题

2

帖子

15

积分
UID 4306
牛币:
13 个

贡献:
0 个

威望:
0 点

我的勋章
13w29dn774 发表于 2019-4-8 13:08:20
回的人少,我来小顶一下
回复

使用道具 举报

0

主题

2

帖子

17

积分
UID 6767
牛币:
15 个

贡献:
0 个

威望:
0 点

我的勋章
i5362ugxr7 发表于 2019-4-8 14:05:34
确实是难得好帖啊,顶先
回复

使用道具 举报

0

主题

1

帖子

13

积分
UID 7476
牛币:
12 个

贡献:
0 个

威望:
0 点

我的勋章
7ack2ju7j3 发表于 2019-4-8 14:05:41
正需要,支持楼主大人了!
回复

使用道具 举报

0

主题

2

帖子

16

积分
UID 5224
牛币:
14 个

贡献:
0 个

威望:
0 点

我的勋章
imhtmzozas 发表于 2019-4-8 14:10:12
回的人少,我来小顶一下
回复

使用道具 举报

0

主题

1

帖子

13

积分
UID 5298
牛币:
12 个

贡献:
0 个

威望:
0 点

我的勋章
czolcwxgde 发表于 2019-4-8 14:45:15
这个帖一般般,还可以哦。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|爬牛论坛.

GMT+8, 2019-8-25 02:20 , Processed in 0.216132 second(s), 28 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表